Technical documentation
发布日期:2023-10-30 浏览次数:1984 来源:杨广成
思科CCIE EI企业基础架构培训-LISP与DMVPN详细配置案例
思科认证EI CCIE培训、学习、考试联系WOLF-LAB网络技术实验室咨询详情
结构如图所示,DMVPN,R1是HUB,R3R4是spoke
首先用DMVPN把三个站点弄通
然后现在在不希望调整DMVPN的情况下,给站点内部设备做LISP,
使得三个站点的VPNA的用户能互通,VPNB的用户也能互通
第一步 完成DMVPN配置
四个模块的配置就不详述了
第二步 R5 R6 R7上创建VRF并且把相应的接口划分进入VRF
R5#sho run | se vrf d|k1|k2
vrf definition A
rd 5:1
!
address-family ipv4
exit-address-family
vrf definition B
rd 5:2
!
address-family ipv4
exit-address-family
interface Loopback1
vrf forwarding A
ip address 10.10.5.1 255.255.255.0
interface Loopback2
vrf forwarding B
ip address 10.10.55.1 255.255.255.0
R6#sho run | se vrf d|k1|k2
vrf definition A
rd 6:1
!
address-family ipv4
exit-address-family
vrf definition B
rd 6:2
!
address-family ipv4
exit-address-family
interface Loopback1
vrf forwarding A
ip address 10.10.6.1 255.255.255.0
interface Loopback2
vrf forwarding B
ip address 10.10.66.1 255.255.255.0
R6#
R7#sho run | se vrf d|k1|k2
vrf definition A
rd 7:1
!
address-family ipv4
exit-address-family
vrf definition B
rd 7:2
!
address-family ipv4
exit-address-family
interface Loopback1
vrf forwarding A
ip address 10.10.7.1 255.255.255.0
interface Loopback2
vrf forwarding B
ip address 10.10.77.1 255.255.255.0
R7#
第三步 R5 R6 R7配置LISP
R7#sho run | se lisp
router lisp
locator-set XTR
IPv4-interface FastEthernet0/0 priority 1 weight 50
exit
!
eid-table vrf A instance-id 1
database-mapping 10.10.7.0/24 locator-set XTR
exit
!
eid-table vrf B instance-id 2
database-mapping 10.10.77.0/24 locator-set XTR
exit
!
site ALL
authentication-key wolf
eid-prefix instance-id 1 10.10.0.0/16 accept-more-specifics
eid-prefix instance-id 2 10.10.0.0/16 accept-more-specifics
exit
!
ipv4 map-server
ipv4 map-resolver
ipv4 itr map-resolver 192.168.7.7
ipv4 itr
ipv4 etr map-server 192.168.7.7 key wolf
ipv4 etr
exit
R5#sho run | se lisp
router lisp
locator-set XTR
IPv4-interface FastEthernet0/0 priority 1 weight 50
exit
!
eid-table vrf A instance-id 1
database-mapping 10.10.5.0/24 locator-set XTR
exit
!
eid-table vrf B instance-id 2
database-mapping 10.10.55.0/25 locator-set XTR
exit
!
ipv4 itr map-resolver 192.168.7.7
ipv4 itr
ipv4 etr map-server 192.168.7.7 key wolf
ipv4 etr
exit
R6#sho run | se lisp
router lisp
locator-set XTR
IPv4-interface FastEthernet0/0 priority 1 weight 50
exit
!
eid-table vrf A instance-id 1
database-mapping 10.10.6.0/24 locator-set XTR
exit
!
eid-table vrf B instance-id 2
database-mapping 10.10.66.0/24 locator-set XTR
exit
!
ipv4 itr map-resolver 192.168.7.7
ipv4 itr
ipv4 etr map-server 192.168.7.7 key wolf
ipv4 etr
exit
第四步 测试
R6#ping vrf A 10.10.7.1 so lo1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.7.1, timeout is 2 seconds:
Packet sent with a source address of 10.10.6.1
..!!!
Success rate is 60 percent (3/5), round-trip min/avg/max = 164/185/200 ms
R6#ping vrf A 10.10.5.1 so lo1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.5.1, timeout is 2 seconds:
Packet sent with a source address of 10.10.6.1
..!!!
Success rate is 60 percent (3/5), round-trip min/avg/max = 260/270/276 ms
R6#
R6#ping vrf B 10.10.77.1 so lo2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.77.1, timeout is 2 seconds:
Packet sent with a source address of 10.10.66.1
..!!!
Success rate is 60 percent (3/5), round-trip min/avg/max = 168/188/224 ms
R6#ping vrf B 10.10.55.1 so lo2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.55.1, timeout is 2 seconds:
Packet sent with a source address of 10.10.66.1
..!!!
Success rate is 60 percent (3/5), round-trip min/avg/max = 252/277/300 ms
R6#
R5#sho ip lisp map-cache eid-table vrf A
LISP IPv4 Mapping Cache for EID-table vrf A (IID 1), 3 entries
0.0.0.0/0, uptime: 00:21:26, expires: never, via static send map-request
Negative cache entry, action: send-map-request
10.10.6.0/24, uptime: 00:04:52, expires: 23:55:00, via map-reply, complete
Locator Uptime State Pri/Wgt
192.168.46.6 00:04:52 up 1/50
10.10.7.0/24, uptime: 00:15:40, expires: 23:44:12, via map-reply, complete
Locator Uptime State Pri/Wgt
192.168.17.7 00:15:40 up 1/50
R5#sho ip lisp map
R5#sho ip lisp map-cache ins
R5#sho ip lisp map-cache instance-id 1
LISP IPv4 Mapping Cache for EID-table vrf A (IID 1), 3 entries
0.0.0.0/0, uptime: 00:21:35, expires: never, via static send map-request
Negative cache entry, action: send-map-request
10.10.6.0/24, uptime: 00:05:01, expires: 23:54:51, via map-reply, complete
Locator Uptime State Pri/Wgt
192.168.46.6 00:05:01 up 1/50
10.10.7.0/24, uptime: 00:15:49, expires: 23:44:03, via map-reply, complete
Locator Uptime State Pri/Wgt
192.168.17.7 00:15:49 up 1/50
R5#sho ip lisp in
R5#sho ip lisp instance-id 1 map
R5#sho ip lisp instance-id 1 map-cache
LISP IPv4 Mapping Cache for EID-table vrf A (IID 1), 3 entries
0.0.0.0/0, uptime: 00:21:42, expires: never, via static send map-request
Negative cache entry, action: send-map-request
10.10.6.0/24, uptime: 00:05:08, expires: 23:54:44, via map-reply, complete
Locator Uptime State Pri/Wgt
192.168.46.6 00:05:08 up 1/50
10.10.7.0/24, uptime: 00:15:56, expires: 23:43:56, via map-reply, complete
Locator Uptime State Pri/Wgt
192.168.17.7 00:15:56 up 1/50
R5#
WOLFLAB官方微信:17316362402
WOLFLAB官方QQ:2569790740
思科认证EI CCIE培训课程学习、考试、咨询价格联系WOLF-LAB网络技术实验室!